Intermittent Call Issues
Incident Report for Mango Voice
Resolved
This incident has been resolved.
Posted Jun 06, 2022 - 06:41 MDT
Update
We are continuing to investigate this issue.
Posted Jun 02, 2022 - 20:37 MDT
Investigating
We are aware of some customers reporting that not all their phones are able to make and receive calls. Our team is investigating the problem and we will provide updates as they become available.
Posted Jun 02, 2022 - 08:21 MDT
This incident affected: US East Phone System (East 2 Voice System).