Portal and Outbound Calls Incident

Incident Report for Mango Voice

Resolved

This incident has been resolved. Any pending call logs will be backfilled throughout today.
Posted May 26, 2026 - 11:48 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 26, 2026 - 11:38 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 26, 2026 - 11:24 MDT

Investigating

We are currently investigating.
Posted May 26, 2026 - 11:07 MDT
This incident affected: US West Phone System (West 1 Voice System, West 2 Voice System), US East Phone System (East 1 Voice System, East 2 Voice System, East 3 Voice System, East 4 Voice System), and Admin Portal, Mobile App, SMS/MMS Messaging, API/Webhooks.