West Coast Voice Disruption
Incident Report for Mango Voice
Resolved
Systems have returned to normal levels. Our team will continue to monitor systems to ensure stability for our users.
Posted Oct 06, 2021 - 12:51 MDT
Monitoring
Our team has identified the issue and our team implemented a solution. We are currently monitoring all systems.
Posted Oct 06, 2021 - 12:42 MDT
Investigating
We are currently investigation voice disruption to some of our West Coast customers. We will provide updates as they become available.
Posted Oct 06, 2021 - 12:34 MDT
This incident affected: US West Phone System (West 1 Voice System).