Voice Disruption
Incident Report for Mango Voice
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 11:53 MST
Monitoring
Services should be returning to normal. If you continue to experience issues, reach out to our support team.
Posted Dec 15, 2021 - 09:14 MST
Identified
We have been notified that Amazon Web Services had widespread connectivity issues across the US. Our team is monitoring systems and will provide updates as they become available.
Posted Dec 15, 2021 - 08:56 MST
Investigating
Our team is monitoring a system disruption that occurred this morning. We will post updates as they become available.
Posted Dec 15, 2021 - 08:47 MST
This incident affected: US West Phone System (West 1 Voice System), US East Phone System (East 1 Voice System), and Admin Portal, Support.