Duplicate email of voicemails
Incident Report for Mango Voice
Resolved
This incident has been resolved.
Posted Feb 24, 2023 - 09:15 MST
Investigating
The tool we use to send emails is having service issues. They aren’t recognizing sent emails therefore they keep sending. We are working with them to resolve this issue and will send an update when one is available.
Posted Feb 22, 2023 - 12:44 MST