Fax Processing Delay
Incident Report for Mango Voice
Resolved
Outbound faxing is now caught up and working as expected. Some faxes may have failed to send during this time.

Please contact support if you need help resending any failed faxes.
Posted Nov 29, 2021 - 11:17 MST
Identified
We're experiencing delays with outbound faxing. They're getting queued but are slow to process.
Posted Nov 29, 2021 - 10:26 MST