Fax Processing Delay
Incident Report for Mango Voice
Resolved
We were able to identify and fix faxes that were in a stuck state. The backlog has been processed and things should be back to normal now.

If you need help retrying any failed faxes please contact support.
Posted Nov 29, 2021 - 16:59 MST
Identified
We're experiencing delays with outbound faxing. Queued faxes are very slow to process.
Posted Nov 29, 2021 - 15:52 MST