Calls Failing or Slow to Complete

Incident Report for Mango Voice

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 10:48 MDT

Monitoring

We are now seeing calls working in both directions.

During the incident, call log reporting processing was paused. We are slowing turning that back on but it will likely take all day to catch up.
Posted Sep 08, 2025 - 09:54 MDT
This incident affected: US West Phone System (West 1 Voice System, West 2 Voice System), US East Phone System (East 1 Voice System, East 2 Voice System, East 3 Voice System, East 4 Voice System), and Admin Portal, Web Phone.